Android Fragments now available for Android 1.6 or higher

Google have released the fragment API which is part of 3.0 as a static library.

Fragements allow screen elements to be broken into framents, that be arranged depending on the screen size of the device. This is great for 3.0 developers that develop for tablets as it allows you to also design for a smaller resolution screen.

Until now this was only available to android 3.0 but the new static library allows anyone that develops for Android 1.6 and higher to import the static library.

This library is available through the SDK Updater; it’s called “Android Compatibility package”.

If you wan to learn more about Fragments and what they can be used for, have a look at this post from Dianne Hackborn.

, , , , , ,

  1. No comments yet.
(will not be published)